Każda wersja MinecraftPlus działa tak samo jak oryginalny Minecraft. Do uruchomienia gry potrzebny jest launcher Minecraft (dowolny, obsługujący oryginalne pliki konfiguracyjne .json).

Pobieranie klienta MC+

Aby uruchomić klienta gry w wydaniu MiecraftPlus musisz pobrać odpowiednią konfigurację wersji z poniższej listy, a następnie ją zainstalować.
W przypadku problemu z pobieraniem, kliknij na link PPM i wybierz "Zapisz link jako...".

Nazwa wydania Wersja Bazowa wersja* Link
Cannon Update 0.0.2 1.15.2 pobierz
0.0.1 pobierz
0.0.1-SNAPSHOT pobierz
Zero Update 0.0.0 pobierz
* wersja oryginalnej wersji gry której zawartość jest obecna w danej wersji MC+

Jeśli napotkasz błąd w MinecraftPlus, masz pomysł na ulepszenie lub dodanie nowej funkcjonalności zgłoś to pod tym linkiem.

Instalacja klienta MC+

Pobrany plik konfiguracyjny wersji minecraftplus-x.x.x.json (lub dla wersji przejściowych minecraftplus-x.x.x-SNAPSHOT.json) należy umieścić w folderze o takiej samej nazwie jak plik, bez rozszerzenia .json. Tak przygotowany folder z zawartym w nim plikiem konfiguracyjnym, należy przenieść do folderu wersji .minecraft/versions/ (najczęściej jest to %appdata%/.minecraft/versions/) z którego korzysta używany launcher Minecraft.

Uruchamianie klienta MC+

Aby uruchomić grę w wersji MinecraftPlus należy w launcherze gry dodać nową wersję. W tym celu należy skonfigurować nową instalację, która wykorzystywać będzie pobraną konfigurację wersji gry. Należy zwrócić uwagę na rodzaj pobranej konfiguracji - w przypadku gdy nazwa zawiera słowo SNAPSHOT jest to wydanie przejściowe i w launcherze należy odblokować używanie wersji przejściowych.

Uruchamianie Spigot+

Uruchomienie serwera SpigotPlus jest analogiczne jak w przypadku standardowego serwera Spigot.

Aby uruchomić serwer SpigotPlus musisz pobrać gotowy silnik z poniższej listy.
W przypadku problemu z pobieraniem, kliknij na link PPM i wybierz "Zapisz link jako...".

Wersja Kompatybilność Link
Wydanie MC+ API Pluginy*
0.0.2 Cannon Update 0.0.2 0.0.2 Spigot 1.15.2 pobierz
0.0.1-SNAPSHOT 0.0.1 0.0.2-SNAPSHOT pobierz
0.0.0 Zero Update 0.0.0 0.0.1 pobierz
* zgodność z pluginami jest zapewniana na poziomie API; pluginy lub ich funkcjonalności wykraczające poza zakres Spigot+API mogą być niekompatybilne z silnikiem Spigot+ ze względu na jego odmienną strukturę względem oryginalnego silnika Spigot.

Jeśli napotkasz błąd w SpigotPlus, masz pomysł na ulepszenie lub dodanie nowej funkcjonalności zgłoś to pod tym linkiem.

Spigot+ API

API pozwalające na integrację pluginów z nowościami wniesionymi przez aktualizacje zostanie udostępnione w najbliższym czasie, gdy repozytorium projektu zostanie przeniesione do publicznego dostępu.
Jeśli potrzebujesz dostępu do API już teraz, skontaktuj się z nami na naszym discordzie.